Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[gelöst] grub install in der partition funkt nicht
12-12-2010, 11:06 AM (This post was last modified: 12-22-2010 11:09 AM by hoodrobin.)
Post: #1
[gelöst] grub install in der partition funkt nicht
hallo!
da ich mehrere systeme parallel auf meinem laptop laufen habe und diese mit GAG als bootloader ansteuere, installiere ich grub immer in der jeweiligen partition. das schien soweit auch funktioniert zu haben, nur kann GAG nach der neptune 1.9.1- installation den bootsektor nicht finden. ob der grub-install im mbr funktioniert, kann ich nicht sagen.
ich hab das problem dann von außerhalb (grub installation von puppy-linux aus in den bootsektor der neptune-partition) gelöst.
vielleicht taucht das problem noch bei jemand anderem auf.
sg, phil
Find all posts by this user
Quote this message in a reply
12-12-2010, 11:53 AM
Post: #2
RE: grub install in der partition funkt nicht
Hi
ich habe grub bei Neptune eigentlich schon immer in die Partition installiert, da ich auch mehrere Systeme parallel betreibe, das hat auch funktioniert.
Grub2 im MBR hat nach einem "update-grub" im Hauptsystem dies und alle anderen linux + win Systeme immer gut eingebunden.
Bis zur vorigen Version 1.8 basierte Neptune ja auf Debian-Lenny und hatte noch das alte Grub. Obwohl ebenfalls Lenny-basiert verwendete Kanotix-Excalibur dagegen schon immer das aktuellere Grub2, daher hab ich das immer im MBR gelassen und das grub von Neptune in die Partition schreiben lassen.

Es war eher das ubuntu-basierte ZevenOS das sich bei der Installation mit ubiquity bockig zeigte, wenn es nicht in den MBR "durfte", so wie das "normale" ubuntu auch.

BTW "GAG" kannte ich nicht, musste ich erst nachsehen. Hat das irgendwelche Vorteile gegenüber Grub2 ?
Find all posts by this user
Quote this message in a reply
12-12-2010, 10:40 PM
Post: #3
RE: grub install in der partition funkt nicht
also GAG ist eigentlich ein ganz einfacher bootloader, der nur die bootsektoren der bootfähigen partitionen "ansteuert", das heißt es muss in jeder partition wo ein linux, windos, bsd usw. sitzt ein grub, boot.ini etc. installiert sein. der vorteil ist, dass man GAG einfach in den MBR schreibt und dort jederzeit verändern und speichern kann. also wenn sich die partitionierung ändert, die BS-namen usw. einfach ausbessern und speichern, ohne betriebssystem oder installation. für die grub-installation braucht man halt immer ein funktionierendes linux irgendwo und wenn ich viel mit installationen herumspiele ist mir das einfach zu lästig. so nehme ich immer die standard-grub-geschichte während einer installation - aber eben nicht im mbr.
hab gerade gegooglet. GAG scheint probleme mit grub2 zu haben. da liegt dann wohl das problem...
Find all posts by this user
Quote this message in a reply
12-22-2010, 11:15 AM
Post: #4
RE: grub install in der partition funkt nicht
(12-12-2010 10:40 PM)hoodrobin Wrote:  also GAG ist eigentlich ein ganz einfacher bootloader, der nur die bootsektoren der bootfähigen partitionen "ansteuert", das heißt es muss in jeder partition wo ein linux, windos, bsd usw. sitzt ein grub, boot.ini etc. installiert sein. der vorteil ist, dass man GAG einfach in den MBR schreibt und dort jederzeit verändern und speichern kann. also wenn sich die partitionierung ändert, die BS-namen usw. einfach ausbessern und speichern, ohne betriebssystem oder installation. für die grub-installation braucht man halt immer ein funktionierendes linux irgendwo und wenn ich viel mit installationen herumspiele ist mir das einfach zu lästig. so nehme ich immer die standard-grub-geschichte während einer installation - aber eben nicht im mbr.
hab gerade gegooglet. GAG scheint probleme mit grub2 zu haben. da liegt dann wohl das problem...

Edit: Die Grub2-Installation in den Bootsektor der Partition funktioniert einwandfrei.
Wie geschrieben, die Chainloader-Funktion von GAG funktioniert bei Grub2 nicht. Hab stattdessen Grub im MBR installiert und eine kleine Partition mit dem Boot-Folder erstellt. Klassisches Chainloading geht aus der menu.lst heraus auch nicht, aber man kann Grub2 dennoch aufrufen. Kann mich mit Grub2, bzw. dessen umständlicher Konfiguration noch nicht ganz anfreunden...
Find all posts by this user
Quote this message in a reply
12-22-2010, 01:36 PM
Post: #5
RE: [gelöst] grub install in der partition funkt nicht
(12-22-2010 11:15 AM)hoodrobin Wrote:  Kann mich mit Grub2, bzw. dessen umständlicher Konfiguration noch nicht ganz anfreunden...

Gerade aus sicht eines Entwicklers ist die Konfiguration bei Grub2 einfacher geworden, da man Konfigurationsfiles schreiben kann, die für jede Distri oder OS anders aussehen kann. Das hat enorme Vorteile.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)