Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Virtual machine not starting.
12-07-2018, 02:04 AM
Post: #1
Virtual machine not starting.
In virtual box, the virtual machine fails to start. The terminal output is-
Quote:jagdeesh@jld-lap-nep5:~$ virtualbox
WARNING: The character device /dev/vboxdrv does not exist.
Please install the virtualbox-dkms package and the appropriate
headers, most likely linux-headers-amd64.

You will not be able to start VMs until this problem is fixed.
Should I install 'virtualbox-guest-dkms' and 'virtualbox-guest-utils'? Which headers precisely need to be installed?
I am running
Quote:jagdeesh@jld-lap-nep5:~$ uname -r
4.18.0-0.bpo.1-amd64

-Jagdeesh.
Find all posts by this user
Quote this message in a reply
12-07-2018, 10:46 AM
Post: #2
RE: Virtual machine not starting.
Virtualbox-guest stuff is only needed for running in a virtualbox as a guest. So not for running virtualbox itself.
If the virtualbox-dkms package is not working for you it might be a debian issue as the kernel is too new for the virtualbox package to support
Visit this user's website Find all posts by this user
Quote this message in a reply
12-25-2018, 10:25 PM (This post was last modified: 12-25-2018 10:44 PM by DDSchwede.)
Post: #3
RE: Virtual machine not starting.
(12-07-2018 02:04 AM)Jag59 Wrote:  In virtual box, the virtual machine fails to start. The terminal output is-
Quote:jagdeesh@jld-lap-nep5:~$ virtualbox
WARNING: The character device /dev/vboxdrv does not exist.
Please install the virtualbox-dkms package and the appropriate
headers, most likely linux-headers-amd64.

You will not be able to start VMs until this problem is fixed.
Should I install 'virtualbox-guest-dkms' and 'virtualbox-guest-utils'? Which headers precisely need to be installed?
I am running
Quote:jagdeesh@jld-lap-nep5:~$ uname -r
4.18.0-0.bpo.1-amd64

Same for me, wont start any of my VMs.

From the CLI i get:
VBoxManage startvm "FMVSNMP1"
WARNING: The character device /dev/vboxdrv does not exist.
Please install the virtualbox-dkms package and the appropriate
headers, most likely linux-headers-amd64.

You will not be able to start VMs until this problem is fixed.
Waiting for VM "FMVSNMP1" to power on...
VBoxManage: error: The virtual machine 'FMVSNMP1' has terminated unexpectedly during startup with exit code 1 (0x1)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MachineWrap, interface IMachine

And from apt-get - install virtualbox-dkms:

Reading package lists... Done
Building dependency tree
Reading state information... Done
virtualbox-dkms is already the newest version (5.2.10-dfsg-6~bpo9+2neptune1).
The following packages were automatically installed and are no longer required:
linux-headers-4.17.0-0.bpo.1-amd64 linux-headers-4.17.0-0.bpo.1-common
linux-headers-4.17.0-0.bpo.3-amd64 linux-headers-4.17.0-0.bpo.3-common
linux-image-4.17.0-0.bpo.1-amd64 linux-image-4.17.0-0.bpo.3-amd64 linux-kbuild-4.17
python-testresources python-testscenarios python3-dateutil python3-editor python3-sqlalchemy
python3-sqlalchemy-ext
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


As for the question, "dkms-xxx" is the kernel module nedded on the host machine and the "xxx-guestutils", you run on the guestmachines.
Find all posts by this user
Quote this message in a reply
12-26-2018, 10:42 AM
Post: #4
RE: Virtual machine not starting.
I don't have time right now but this seems like the solution: https://forums.virtualbox.org/viewtopic....84#p436700
Find all posts by this user
Quote this message in a reply
01-05-2019, 01:10 PM
Post: #5
RE: Virtual machine not starting.
Hallo
ich hänge mich da mal dran, statt im deutschen Forum einen neues Thema zu setzen. Inhaltlich ist es das gleiche oder ein ähnliches Problem.
Virtualbox ladet kein iso sondert meldet bei starten:
Quote:Für die virtuelle Maschine KX konnte keine neue Sitzung eröffnet werden.
The virtual machine 'KX' has terminated unexpectedly during startup with exit code 1 (0x1).
Fehlercode:NS_ERROR_FAILURE (0x80004005)
Komponente:MachineWrap
Interface:IMachine {85cd948e-a71f-4289-281e-0ca7ad48cd89}

Zum Vergleich: bei *buntu 18.04 LTS, und einem aktuellen "Buster"-Derivat läuft es einwandfrei. Die Kernelversion kann es somit nicht sein. Neptune ist momentan als einziges installiert auf Debian-stretch Basis
Find all posts by this user
Quote this message in a reply
01-05-2019, 06:23 PM
Post: #6
RE: Virtual machine not starting.
Läuft bei mir ohne Probleme. Hast du vielleicht ein BIOS Update gemacht?
Visit this user's website Find all posts by this user
Quote this message in a reply
01-07-2019, 11:32 AM
Post: #7
RE: Virtual machine not starting.
(01-05-2019 06:23 PM)leszek Wrote:  Läuft bei mir ohne Probleme. Hast du vielleicht ein BIOS Update gemacht?
Bewusst nicht aber möglicherweise unabsichtlich. Am Gerät ist nun mal Win10 vorinstalliert und SecureBoot. Daher ist auch zunächst *buntu installiert. Hernach habe ich Neptune installiert. Im legacy mode. Schaltet man im BIOS secureboot aus ist UEFI angegraut, geht dann nur legacy. Neptune startet dann mit grub-menü von *buntu.
Testiso mit buster-system war zuletzt, da funktioniert vbox. Während Neptune installiert war, war auch der signierte bootloader von U* beim Update ein paar mal dabei. Hat Neptune bis jetzt nicht gestört. Außer vbox.
Habe zwischenzeitlich festgestellt, dass LMDE auch mit secureboot startet. Wäre halt schön, wenn der normale Anwender ein stabiles Debian-System nach Wahl startet ohne BIOS-Gefummel.
Find all posts by this user
Quote this message in a reply
01-08-2019, 02:58 PM
Post: #8
RE: Virtual machine not starting.
(01-07-2019 11:32 AM)Eppo Wrote:  Wäre halt schön, wenn der normale Anwender ein stabiles Debian-System nach Wahl startet ohne BIOS-Gefummel.
Letzeres hat sich wohl erledigt wenn Neptune auf "Buster"-Basis läuft:
https://www.pro-linux.de/news/1/26644/de...-boot.html
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)