Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Debian repo not updated
11-29-2018, 03:55 PM
Post: #1
Debian repo not updated
I'm running stock Debian with the Neptune KDE repo on top (massive thanks for this... its really nice to have a more up to date version of KDE). It doesn't look like the Debian repo has been updated to include the latest Plasma and KDE applications that are in Neptune 5.6. For plasma, it looks like I'm still on 5.12.0...

Code:
# apt search plasma-desktop
Sorting... Done
Full Text Search... Done
kde-plasma-desktop/stable,now 5:99neptune1 amd64 [installed,automatic]
  KDE Plasma Desktop and minimal set of applications

plasma-desktop/stable,now 4:5.12.0-0neon+neptune9 amd64 [installed,automatic]
  Tools and widgets for the desktop

I'm not sure exactly which package to check for KDE apps, but different apps are showing different versions, none of which are 8.08.2...

Code:
root@scrumpy:~ # apt search kde-baseapps
Sorting... Done
Full Text Search... Done
kde-baseapps/stable,now 4:17.08.3+5.99neptune1 amd64 [installed,automatic]
  base applications from the official KDE release (metapackage)

root@scrumpy:~ # apt search konsole
Sorting... Done
Full Text Search... Done
konsole/stable,now 4:18.08.0-2 amd64 [installed]
  X terminal emulator

root@scrumpy:~ # apt search dolphin
Sorting... Done
Full Text Search... Done
dolphin/stable,now 4:18.04.0-0neon+neptune7 amd64 [installed,automatic]
  file manager

Are there any plans to update the debian add-on repo?
Find all posts by this user
Quote this message in a reply
11-29-2018, 04:45 PM
Post: #2
RE: Debian repo not updated
The repo is actually up to date. Though because of the Qt 5.7 compatibility we have to take the patches from newer Plasma versions or KDE App versions and KF5 and apply them to our packaging. Thats why the package version numbers stay on an older number.
Though kinfocenter should show you the correct Plasma version and KDE Applications version.
KF5 version might be off by a little there too as we did not update all KF5 packages to the latest version.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-29-2018, 04:51 PM
Post: #3
RE: Debian repo not updated
(11-29-2018 04:45 PM)leszek Wrote:  The repo is actually up to date. Though because of the Qt 5.7 compatibility we have to take the patches from newer Plasma versions or KDE App versions and KF5 and apply them to our packaging. Thats why the package version numbers stay on an older number.
Though kinfocenter should show you the correct Plasma version and KDE Applications version.
KF5 version might be off by a little there too as we did not update all KF5 packages to the latest version.

OK, thanks for the explanation. I find KDE version numbering very confusing due to the separate plasma, frameworks and applications version numbers.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)