Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Update Abhaengigkeiten
05-16-2018, 09:43 AM
Post: #1
Update Abhaengigkeiten
Hi,

mal wieder ein Problem bei einem update.

Weder apt-get/aptitude noch discover koennen aktuell die Pakete zu upgrade aufloesen

Code:
root@druuhl:/home/druuhl# apt-get upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  linux-image-4.13.0-0.bpo.1-amd64 linux-image-4.14.0-0.bpo.2-amd64
Use 'apt autoremove' to remove them.
The following packages have been kept back:
  kde-standard kdeutils libegl-nvidia0 libegl-nvidia0:i386 libegl1-glvnd-nvidia libegl1-glvnd-nvidia:i386 libegl1-mesa libgbm1 libgl1-glvnd-nvidia-glx libgl1-glvnd-nvidia-glx:i386 libgl1-mesa-dri
  libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libgl1-nvidia-glvnd-glx libgl1-nvidia-glvnd-glx:i386 libglapi-mesa libglapi-mesa:i386 libgles-nvidia1 libgles-nvidia1:i386 libgles-nvidia2
  libgles-nvidia2:i386 libgles1-glvnd-nvidia libgles1-glvnd-nvidia:i386 libgles2-glvnd-nvidia libgles2-glvnd-nvidia:i386 libgles2-mesa libglx-nvidia0 libglx-nvidia0:i386 libglx0-glvnd-nvidia
  libglx0-glvnd-nvidia:i386 libnvidia-cfg1 libnvidia-cfg1:i386 libnvidia-egl-wayland1 libnvidia-eglcore libnvidia-eglcore:i386 libnvidia-glcore libnvidia-glcore:i386 libnvidia-ml1 libwayland-egl1-mesa
  libxatracker2 linux-headers-amd64 linux-image-amd64 mesa-va-drivers mesa-vdpau-drivers nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-driver-libs nvidia-driver-libs:i386 nvidia-egl-icd
  nvidia-egl-icd:i386 nvidia-egl-wayland-icd nvidia-kernel-support nvidia-vdpau-driver nvidia-vulkan-icd nvidia-vulkan-icd:i386 qml-module-qtquick-virtualkeyboard xserver-xorg-video-nvidia
The following packages will be upgraded:
  libuv1 rake
2 upgraded, 0 newly installed, 0 to remove and 59 not upgraded.
1 not fully installed or removed.
Need to get 165 kB of archives.
After this operation, 30.7 kB of additional disk space will be used.
Find all posts by this user
Quote this message in a reply
05-17-2018, 08:54 AM (This post was last modified: 05-17-2018 11:36 AM by leszek.)
Post: #2
RE: Update Abhaengigkeiten
Ich sehe hier keinen Fehler. Da du nvidia Zeugs installiert hast vermute ich dass dies hier wieder einen Konflikt verursachen, der dazu führt das viele Pakete zurückgehalten werden.
Visit this user's website Find all posts by this user
Quote this message in a reply
05-18-2018, 12:27 PM
Post: #3
RE: Update Abhaengigkeiten
Ich habe jetzt manuell die upgrades erledigt und nun bleiben nur noch die nvidia Pakete die Probleme verursachen. Leider die einzige Moeglichkeit mein Setup auf Arbeit zu betreiben
Find all posts by this user
Quote this message in a reply
05-28-2018, 01:32 PM
Post: #4
RE: Update Abhaengigkeiten
Nach ein wenig rumprobieren, also

- apt-get upgrade $EinzelPakete

Ergibt sich folgendes Bild
Code:
root@druuhl:/home/druuhl# apt-get upgrade libwayland-egl1-mesa
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libegl1-glvnd-nvidia : Conflicts: libegl1 (> 0) but 1.0.0+git20180308-2~bpo9+1 is to be installed
libegl1-glvnd-nvidia:i386 : Conflicts: libegl1 (> 0) but 1.0.0+git20180308-2~bpo9+1 is to be installed
libglvnd0-nvidia : Conflicts: libglvnd0 but 1.0.0+git20180308-2~bpo9+1 is to be installed
libglvnd0-nvidia:i386 : Conflicts: libglvnd0 but 1.0.0+git20180308-2~bpo9+1 is to be installed
nvidia-driver-libs : Conflicts: libegl1 (> 0) but 1.0.0+git20180308-2~bpo9+1 is to be installed
                      Conflicts: libegl1-mesa (>= 17) but 17.3.9-1~bpo9+1 is to be installed
                      Conflicts: libglvnd0 (> 0) but 1.0.0+git20180308-2~bpo9+1 is to be installed
nvidia-driver-libs:i386 : Conflicts: libegl1 (> 0) but 1.0.0+git20180308-2~bpo9+1 is to be installed
                           Conflicts: libegl1-mesa (>= 17) but 17.3.9-1~bpo9+1 is to be installed
                           Conflicts: libglvnd0 (> 0) but 1.0.0+git20180308-2~bpo9+1 is to be installed
                           Recommends: nvidia-egl-wayland-icd:i386 (= 390.48-2~bpo9+3) but it is not going to be installed
E: Broken packages
root@druuhl:/home/druuhl# apt-get upgrade libgles2-mesa
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgles2-glvnd-nvidia : Conflicts: libgles2 (> 0)
libgles2-glvnd-nvidia:i386 : Conflicts: libgles2 (> 0)
libglvnd0-nvidia : Conflicts: libglvnd0 but 1.0.0+git20180308-2~bpo9+1 is to be installed
libglvnd0-nvidia:i386 : Conflicts: libglvnd0 but 1.0.0+git20180308-2~bpo9+1 is to be installed
nvidia-driver-libs : Conflicts: libgles2 (> 0)
                      Conflicts: libgles2-mesa (>= 17) but 17.3.9-1~bpo9+1 is to be installed
                      Conflicts: libglvnd0 (> 0) but 1.0.0+git20180308-2~bpo9+1 is to be installed
nvidia-driver-libs:i386 : Conflicts: libgles2 (> 0)
                           Conflicts: libgles2-mesa (>= 17) but 17.3.9-1~bpo9+1 is to be installed
                           Conflicts: libglvnd0 (> 0) but 1.0.0+git20180308-2~bpo9+1 is to be installed
                           Recommends: nvidia-egl-wayland-icd:i386 (= 390.48-2~bpo9+3) but it is not going to be installed
E: Broken packages
root@druuhl:/home/druuhl# apt-get upgrade libglapi-mesa
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgl1-mesa-glx : Depends: libglapi-mesa (= 13.0.6-1+b2) but 17.3.9-1~bpo9+1 is to be installed
libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 13.0.6-1+b2) but 17.3.9-1~bpo9+1 is to be installed
libgles2-mesa : Depends: libglapi-mesa (= 13.0.6-1+b2) but 17.3.9-1~bpo9+1 is to be installed
E: Broken packages

Es haengt an Mesa
Code:
apt-get upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  e2fsprogs-l10n libcom-err2:i386 libcomerr2:i386 libegl1-mesa libgbm1 libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libgles2-mesa
  libwayland-egl1-mesa
Find all posts by this user
Quote this message in a reply
05-29-2018, 01:18 PM
Post: #5
RE: Update Abhaengigkeiten
Also Debian Backports verteilt Mesa Updates.

libgl1-mesa-glx und libgles2-mesa liegen in einer 17er Version in Backports.
Sprich die beiden können nicht das Problem sein.

Versuch die mal zu installieren und schaue was es an Fehlern liefert, mach das solange (also die Pakete updaten die meckern, dass die von einer alten Version 13 abhängen) bis es ein Paket auftaucht für das keine 17er Version mehr existiert, dass wird dann der Übeltäter sein.
Visit this user's website Find all posts by this user
Quote this message in a reply
06-08-2018, 12:55 PM
Post: #6
RE: Update Abhaengigkeiten
Nach einer Weile "solange ich nicht hinsehe, ist es nicht da" hat sich das Problem durch Debian erledigtWink upgrade funzt wieder sauber

gruss Stefan
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)