Post Reply 
 
Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[solved][neptune 4.1]14.4 FGLRX driver in the repo doesn't patched for current kernel
10-24-2014, 05:32 AM (This post was last modified: 10-25-2014 06:05 PM by dib.)
Post: #1
[solved][neptune 4.1]14.4 FGLRX driver in the repo doesn't patched for current kernel
Hi,

First of all, great distro, I like it very mutch! Cool I recently switched from (K)ubuntu, and I don't regret it... Big Grin

I'm using neptune 4.1, and I was able to install the fglrx-driver (14.4~rc1.0apr17-neptune1 from unstable) using the HW manager. However after running
Code:
aticonfig --initial
and restarted, the driver wasn't loaded correctly,
Code:
fglrxinfo
doesnt gave the correct info back. I've researched a little, and found out, that the last compatible Kernel is 3.13, and my current Kernel is 3.14.13. So it seems the driver is not patched for 3.13+ kernel versions. I started to look after ways to patch it, but I was unlucky with the install after that. :-(
Can you patch the driver in the repo? I've seen that 14.9 is also out, is there a slight chance, that the driver will be upgraded in the repo till the neptune 4.2 (or 5)? In the meantime I swiched back to 3.13.xx kernel, because I was unable to build the fglrx packages from the 14.9 package downloaded from AMD. Angry It complains about a missing folder:

Code:
Generating package: Debian/stable
cp: cannot stat `/home/dib/catalyst14.9/fglrx-14.301.1001/fglrx-install.JJgixX/x710_64a/*': No such file or directory
Package build failed!
Package build utility output:
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 14.301.1001-1
dpkg-buildpackage: source changed by AMD: Advanced Micro Devices. <http://ati.amd.com/support/driver.html>
dpkg-source --before-build fglrx.DwPVpK
dpkg-buildpackage: host architecture amd64
debian/rules build
dh_testdir
# move licenses away from binary dir
if [ ! -d usr/share/doc/fglrx ]; then \
          mkdir -p usr/share/doc/fglrx; \
          mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
        fi
# set executable on user apps
find usr/X11R6/bin -type f | xargs chmod a+x
# remove exec bit from files that don't deserve it
find usr/X11R6/include \
             usr/X11R6/lib \
             usr/X11R6/lib64 \
             usr/share usr/src     -type f | xargs chmod -x
find: `usr/X11R6/include': No such file or directory
find lib -not -name "*.sh" -type f | xargs chmod -x
find lib      -name "*.sh" -type f | xargs chmod +x
# set proper permissions on /etc files
if [ -d etc/ati ]; then                 \
                chmod 755 etc/ati ;                     \
                chmod 644 etc/ati/* ;           \
                chmod a+x etc/ati/*.sh ;        \
        fi
if [ -f debian/fglrx.default ]; then \
          mv -v debian/fglrx.default debian/fglrx; \
        fi
`debian/fglrx.default' -> `debian/fglrx'
# remove exec bit from 64-bit libs too
find usr/X11R6/lib64       -type f | xargs chmod -x
debian/rules binary
dh_testdir
# move licenses away from binary dir
if [ ! -d usr/share/doc/fglrx ]; then \
          mkdir -p usr/share/doc/fglrx; \
          mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
        fi
# set executable on user apps
find usr/X11R6/bin -type f | xargs chmod a+x
# remove exec bit from files that don't deserve it
find usr/X11R6/include \
             usr/X11R6/lib \
             usr/X11R6/lib64 \
             usr/share usr/src     -type f | xargs chmod -x
find: `usr/X11R6/include': No such file or directory
find lib -not -name "*.sh" -type f | xargs chmod -x
find lib      -name "*.sh" -type f | xargs chmod +x
# set proper permissions on /etc files
if [ -d etc/ati ]; then                 \
                chmod 755 etc/ati ;                     \
                chmod 644 etc/ati/* ;           \
                chmod a+x etc/ati/*.sh ;        \
        fi
if [ -f debian/fglrx.default ]; then \
          mv -v debian/fglrx.default debian/fglrx; \
        fi
# remove exec bit from 64-bit libs too
find usr/X11R6/lib64       -type f | xargs chmod -x
dh_testdir
dh_testroot
dh_clean -k
dh_clean: dh_clean -k is deprecated; use dh_prep instead
dh_clean: Compatibility levels before 5 are deprecated (level 4 in use)
dh_installdirs
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
# Create the directories to install into
dh_installdirs -pfglrx-driver \
                usr \
                usr/lib/xorg \
                usr/lib/xorg/modules \
                usr/lib/dri \
                usr/bin \
                usr/sbin \
                etc/acpi \
                etc/acpi/events \
                etc/default \
                etc/X11/Xsession.d
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
# the amd64 package includes 32bit compatibility libraries
dh_installdirs -pfglrx-driver \
                emul/ia32-linux/usr/lib \
                emul/ia32-linux/usr/lib/xorg \
                emul/ia32-linux/usr/lib/xorg/modules \
                emul/ia32-linux/usr/lib/dri
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
dh_installdirs -pfglrx-driver-dev \
                usr \
                usr/include \
                usr/lib
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
dh_installdirs -pfglrx-kernel-src \
                usr/src/modules/fglrx \
                usr/src/modules/fglrx/debian
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
dh_installdirs -A -pfglrx-amdcccle \
                usr \
                usr/bin \
                usr/share \
                usr/share/applnk \
                usr/share/applications \
                usr/share/icons \
                usr/share/pixmaps
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
dh_installdirs -p \
                usr/src
dh_installdirs: Compatibility levels before 5 are deprecated (level 4 in use)
dh_install
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
dh_install -pfglrx-driver "usr/X11R6/bin/fgl*"      "usr/bin"
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
dh_install -pfglrx-driver "usr/X11R6/bin/aticonfig" "usr/bin"
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
dh_install -pfglrx-driver "usr/sbin/atieventsd"     "usr/sbin"
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
dh_installman -pfglrx-driver "usr/share/man/man8/atieventsd.8"
dh_installman: Compatibility levels before 5 are deprecated (level 4 in use)
# amd64 needs some library redirection
dh_install -pfglrx-driver "usr/X11R6/lib64/*.so*"           "usr/lib"
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
dh_install -pfglrx-driver "usr/X11R6/lib64/modules/dri"     "usr/lib"
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
dh_install -pfglrx-driver "usr/X11R6/lib64/modules/linux"   "usr/lib/xorg/modules"
dh_install: Compatibility levels before 5 are deprecated (level 4 in use)
cp: cannot stat `./usr/X11R6/lib64/modules/linux': No such file or directory
dh_install: cp -a ./usr/X11R6/lib64/modules/linux debian/fglrx-driver/usr/lib/xorg/modules/ returned exit code 1
make: *** [binary] Error 2
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
Removing temporary directory: fglrx-install.JJgixX
I faced similar problems building 14.6 also :-(
Can you assist me a little further, I've searched google, but I've found little info how to solve this Undecided Huh

Thanks!

dib
Find all posts by this user
Quote this message in a reply
10-24-2014, 10:22 AM
Post: #2
RE: [neptune 4.1]14.4 FGLRX driver in the repo doesn't patched for current neptune kernel
We'll investigate that.
Visit this user's website Find all posts by this user
Quote this message in a reply
10-24-2014, 11:28 AM
Post: #3
RE: [neptune 4.1]14.4 FGLRX driver in the repo doesn't patched for current neptune kernel
Update: Fglrx 14.6 uploaded now to our repo. This should fix your issue and hopefully is also compatible with the kernel 3.16.3 we ship with Neptune 4.2.
14.9 is despite the fact numbered this way not packages yet in debian (they had to revert it because of incompatibilities to the Xserver). Therefore we only packaged 14.6 for now.
Visit this user's website Find all posts by this user
Quote this message in a reply
10-24-2014, 07:03 PM
Post: #4
Thumbs Up [solved][neptune 4.1]14.4 FGLRX driver in the repo doesn't patched for current kernel
(10-24-2014 11:28 AM)leszek Wrote:  Update: Fglrx 14.6 uploaded now to our repo. This should fix your issue and hopefully is also compatible with the kernel 3.16.3 we ship with Neptune 4.2.
14.9 is despite the fact numbered this way not packages yet in debian (they had to revert it because of incompatibilities to the Xserver). Therefore we only packaged 14.6 for now.

Wow, that was a quick fix, great support! Thanks a lot! Cool
I love this distro more day by day! Big Grin
Keep up the good work! By the way how can I donate to the neptune team?
Find all posts by this user
Quote this message in a reply
10-24-2014, 08:47 PM
Post: #5
RE: [solved][neptune 4.1]14.4 FGLRX driver in the repo doesn't patched for current kernel
On the neptuneos.com website there is a PayPal donate button on the downloadpage.
Visit this user's website Find all posts by this user
Quote this message in a reply
10-25-2014, 12:36 AM
Post: #6
RE: [solved][neptune 4.1]14.4 FGLRX driver in the repo doesn't patched for current kernel
(10-24-2014 08:47 PM)leszek Wrote:  On the neptuneos.com website there is a PayPal donate button on the downloadpage.

Thanks, I remember that I saw that button, just don't know where... :facepalm:
Done, not mutch, but may cover some beers, cheers and neptune rulez! :-)
Find all posts by this user
Quote this message in a reply
10-25-2014, 03:42 PM
Post: #7
Lightbulb [neptune 4.1]FGLRX driver for i386 arch. is still 14.4 in the repo
(10-24-2014 11:28 AM)leszek Wrote:  Update: Fglrx 14.6 uploaded now to our repo. This should fix your issue and hopefully is also compatible with the kernel 3.16.3 we ship with Neptune 4.2.
14.9 is despite the fact numbered this way not packages yet in debian (they had to revert it because of incompatibilities to the Xserver). Therefore we only packaged 14.6 for now.

Update: I've installed Steam, and Playonlinux, and during that I've found out, that the i386 packages are still the "old" ones in the repo. (Like llibgl1-fglrx-glx:i386 is still 1:14.4~rc1.0.apr17-neptune1). Please update those to, because Steam and Playonlinux (Wine) still using those. Undecided
Thanks a lot in advance! Cool
Find all posts by this user
Quote this message in a reply
10-25-2014, 04:56 PM
Post: #8
RE: [solved][neptune 4.1]14.4 FGLRX driver in the repo doesn't patched for current kernel
Done.
Thanks for notifying. Someone forgot to upload them Tongue
Visit this user's website Find all posts by this user
Quote this message in a reply
10-25-2014, 05:04 PM (This post was last modified: 04-15-2015 09:48 PM by dib.)
Post: #9
Thumbs Up RE: [solved][neptune 4.1]14.4 FGLRX driver in the repo doesn't patched for current kernel
(10-25-2014 04:56 PM)leszek Wrote:  Done.
Thanks for notifying. Someone forgot to upload them Tongue

NP Tongue
Thanks again for the quick response! Cool

Update: Wheezy-backports is updated with fglrx 14.09, and it solves some graphical glitches. Tongue Can you update the fglrx drivers again in the repo? Shy Thanks in advance! Cool
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)