Forums
Sperrbildschirm ausser Funktion [gelöst] - Printable Version

+- Forums (https://www.zevenos.com/forum)
+-- Forum: General (/forumdisplay.php?fid=1)
+--- Forum: Neptune (/forumdisplay.php?fid=21)
+---- Forum: Deutsches Unterforum (/forumdisplay.php?fid=26)
+----- Forum: Bugs / Fehler (/forumdisplay.php?fid=27)
+----- Thread: Sperrbildschirm ausser Funktion [gelöst] (/showthread.php?tid=21296)

Pages: 1 2


Sperrbildschirm ausser Funktion [gelöst] - druuhl - 01-08-2018 03:47 PM

Hi,

seit dem Update heute funzt der Sperrbildschirm nicht mehr, bzw. nur suboptimal.
Es kommt die Meldung "Zum entsperrn auf per strg+f2 konsole wechseln und Befehl 'loginctl unlock-sessions' ausfuehren und mit strg+f7 wieder zurueckkehren"

Im syslog finde ich dazu folgendes

Code:
Jan  8 14:26:03 druuhl org.kde.kpasswdserver[864]: org.kde.kio.kpasswdserver: User = "" , WindowId = 0
Jan  8 14:26:04 druuhl org.kde.kpasswdserver[864]: org.kde.kio.kpasswdserver: User = "" , WindowId = 0
Jan  8 14:26:04 druuhl org.kde.kpasswdserver[864]: org.kde.kio.kpasswdserver: User = "" , WindowId = 0
Jan  8 14:26:04 druuhl org.kde.kpasswdserver[864]: org.kde.kio.kpasswdserver: User = "" , WindowId = 0
Jan  8 14:26:05 druuhl org.kde.kpasswdserver[864]: org.kde.kio.kpasswdserver: User = "" , WindowId = 0
Jan  8 14:26:06 druuhl PackageKit: refresh-cache transaction /269_eaebedbd from uid 1000 finished with success after 1506ms
Jan  8 14:26:07 druuhl PackageKit: get-updates transaction /270_deeaeace from uid 1000 finished with success after 1377ms
Jan  8 14:26:07 druuhl PackageKit: get-updates transaction /271_daebddea from uid 1000 finished with success after 451ms
Jan  8 14:26:09 druuhl PackageKit: get-updates transaction /272_beeccece from uid 1000 finished with success after 475ms
Jan  8 14:31:03 druuhl org.kde.kpasswdserver[864]: org.kde.kio.kpasswdserver: User = "" , WindowId = 0
Jan  8 14:31:04 druuhl org.kde.kpasswdserver[864]: org.kde.kio.kpasswdserver: User = "" , WindowId = 0
Jan  8 14:31:04 druuhl org.kde.kpasswdserver[864]: org.kde.kio.kpasswdserver: User = "" , WindowId = 0
Jan  8 14:31:04 druuhl org.kde.kpasswdserver[864]: org.kde.kio.kpasswdserver: User = "" , WindowId = 0
Jan  8 14:31:05 druuhl org.kde.kpasswdserver[864]: org.kde.kio.kpasswdserver: User = "" , WindowId = 0
Jan  8 14:35:56 druuhl systemd[1]: Starting Cleanup of Temporary Directories...

Bzw. im Netz

- https://bugs.kde.org/show_bug.cgi?id=360489
- https://forums.gentoo.org/viewtopic-t-1053104-start-0.html
- https://forums.opensuse.org/showthread.php/518831-The-screen-locker-is-broken-and-unlocking-is-not-possible-anymore
- https://bugs.launchpad.net/linuxmint/+bug/1597719


RE: Sperrbildschirm ausser Funktion - leszek - 01-08-2018 06:26 PM

Was hattest du denn für ein Update installiert? (Ich vermute systemd wurde geupdated)
Klappt das manuelle in den Lockscreen gehen denn ?
Hast du nach der Aktualisierung neugestartet?


RE: Sperrbildschirm ausser Funktion - druuhl - 01-08-2018 07:04 PM

- Was hattest du denn für ein Update installiert? (Ich vermute systemd wurde geupdated)
Keine Ahnung, kam heute rein, muss morgen mal checken
- Klappt das manuelle in den Lockscreen gehen denn ?
Sperren ist kein Problem, dann kommt aber die Nachricht, und ich muss per konsole entsperren
- Hast du nach der Aktualisierung neugestartet?
jupp


RE: Sperrbildschirm ausser Funktion - leszek - 01-08-2018 08:35 PM

Ich hab gerade auch mal auf das neueste systemd aktualisiert und kann das Problem nicht nachvollziehen. Nach einem Neustart kann ich wunderbar sperren und entsperren.

Kannst du mal checken ob es mit einem neuen User auch klappt?
Evtl. ist da eine Konfigurations/Cache Datei dran Schuld.


RE: Sperrbildschirm ausser Funktion - druuhl - 01-09-2018 09:50 AM

Jetzt wirds lustig

- Neuer User angelegt
- Bildschrim gesperrt - selber Fehler
- Alt+f3 Konsole
- Login als "neuer" User
- loginctl unlock-sessions verlangt das Passwort meines "alten" Users

apt aktionen von Gestern
Code:
Start-Date: 2018-01-08  11:08:59
Commandline: apt-get install linux-headers-amd64 nvidia-driver nvidia-settings
Install: libglx0-glvnd-nvidia:amd64 (384.98-3~bpo9+1, automatic), libglx0-glvnd-nvidia:i386 (384.98-3~bpo9+1, automatic), libvulkan1:amd64 (1.0.39.0+dfsg1-1, automatic), libvulkan1:i386 (1.0.39.0+dfsg1-1, automatic), nvidia-support:amd64 (20151021+4, automatic), libgles-nvidia1:amd64 (384.98-3~bpo9+1, automatic), libgles-nvidia1:i386 (384.98-3~bpo9+1, automatic), libgles-nvidia2:amd64 (384.98-3~bpo9+1, automatic), libgles-nvidia2:i386 (384.98-3~bpo9+1, automatic), nvidia-kernel-common:amd64 (20151021+4, automatic), libnvidia-ml1:amd64 (384.98-3~bpo9+1, automatic), nvidia-vulkan-icd:amd64 (384.98-3~bpo9+1, automatic), nvidia-vulkan-icd:i386 (384.98-3~bpo9+1, automatic), nvidia-driver-libs-i386:i386 (384.98-3~bpo9+1, automatic), nvidia-egl-icd:amd64 (384.98-3~bpo9+1, automatic), nvidia-egl-icd:i386 (384.98-3~bpo9+1, automatic), update-glx:amd64 (0.7.4, automatic), libglvnd0-nvidia:amd64 (384.98-3~bpo9+1, automatic), libglvnd0-nvidia:i386 (384.98-3~bpo9+1, automatic), nvidia-driver:amd64 (384.98-3~bpo9+1), nvidia-modprobe:amd64 (375.26-1, automatic), nvidia-vulkan-common:amd64 (384.98-3~bpo9+1, automatic), nvidia-vdpau-driver:amd64 (384.98-3~bpo9+1, automatic), libgl1-nvidia-glvnd-glx:amd64 (384.98-3~bpo9+1, automatic), libgl1-nvidia-glvnd-glx:i386 (384.98-3~bpo9+1, automatic), libglx-nvidia0:amd64 (384.98-3~bpo9+1, automatic), libglx-nvidia0:i386 (384.98-3~bpo9+1, automatic), glx-alternative-nvidia:amd64 (0.7.4, automatic), libnvidia-egl-wayland1:amd64 (384.98-3~bpo9+1, automatic), libnvidia-egl-wayland1:i386 (384.98-3~bpo9+1, automatic), nvidia-kernel-dkms:amd64 (384.98-3~bpo9+1, automatic), libegl-nvidia0:amd64 (384.98-3~bpo9+1, automatic), libegl-nvidia0:i386 (384.98-3~bpo9+1, automatic), libwayland-client0:i386 (1.12.0-1, automatic), nvidia-egl-common:amd64 (384.98-3~bpo9+1, automatic), libxnvctrl0:amd64 (375.66-1, automatic), libgles1-glvnd-nvidia:amd64 (384.98-3~bpo9+1, automatic), libgles1-glvnd-nvidia:i386 (384.98-3~bpo9+1, automatic), libnvidia-cfg1:amd64 (384.98-3~bpo9+1, automatic), libnvidia-cfg1:i386 (384.98-3~bpo9+1, automatic), nvidia-legacy-check:amd64 (384.98-3~bpo9+1, automatic), nvidia-egl-wayland-icd:amd64 (384.98-3~bpo9+1, automatic), nvidia-egl-wayland-icd:i386 (384.98-3~bpo9+1, automatic), nvidia-kernel-support:amd64 (384.98-3~bpo9+1, automatic), glx-diversions:amd64 (0.7.4, automatic), nvidia-driver-libs:amd64 (384.98-3~bpo9+1, automatic), nvidia-driver-libs:i386 (384.98-3~bpo9+1, automatic), nvidia-driver-bin:amd64 (384.98-3~bpo9+1, automatic), nvidia-persistenced:amd64 (375.26-2, automatic), xserver-xorg-video-nvidia:amd64 (384.98-3~bpo9+1, automatic), nvidia-installer-cleanup:amd64 (20151021+4, automatic), libgl1-glvnd-nvidia-glx:amd64 (384.98-3~bpo9+1, automatic), libgl1-glvnd-nvidia-glx:i386 (384.98-3~bpo9+1, automatic), glx-alternative-mesa:amd64 (0.7.4, automatic), nvidia-egl-wayland-common:amd64 (384.98-3~bpo9+1, automatic), libopengl0-glvnd-nvidia:amd64 (384.98-3~bpo9+1, automatic), libopengl0-glvnd-nvidia:i386 (384.98-3~bpo9+1, automatic), libnvidia-glcore:amd64 (384.98-3~bpo9+1, automatic), libnvidia-glcore:i386 (384.98-3~bpo9+1, automatic), libegl1-glvnd-nvidia:amd64 (384.98-3~bpo9+1, automatic), libegl1-glvnd-nvidia:i386 (384.98-3~bpo9+1, automatic), libwayland-server0:i386 (1.12.0-1, automatic), libgles2-glvnd-nvidia:amd64 (384.98-3~bpo9+1, automatic), libgles2-glvnd-nvidia:i386 (384.98-3~bpo9+1, automatic), libnvidia-eglcore:amd64 (384.98-3~bpo9+1, automatic), libnvidia-eglcore:i386 (384.98-3~bpo9+1, automatic), nvidia-settings:amd64 (375.66-1), nvidia-alternative:amd64 (384.98-3~bpo9+1, automatic)
End-Date: 2018-01-08  11:09:55

Start-Date: 2018-01-08  12:30:37
Requested-By: druuhl (1000)
End-Date: 2018-01-08  12:30:37

Start-Date: 2018-01-08  12:32:46
Commandline: packagekit role='update-packages'
Requested-By: druuhl (1000)
Install: libnss-systemd:amd64 (236-2~bpo9+1, automatic)
Upgrade: libkpimgapicore5:amd64 (17.04.1-0neon+20170531+backports+build2, 17.08.3-1neptune1), kio-sieve:amd64 (4:17.04.1-0neon+20170531+backports+build9, 4:17.08.3-1neptune1), kio-smtp:amd64 (17.04.1-0neon+20170531+backports+build8, 17.08.3-1neptune1), libkf5pimtextedit-plugins:amd64 (17.04.1-0neon+20170531+backports+build5, 17.08.3-1neptune1), libkf5holidays5:amd64 (17.04.1-0neon+20170531+backports+build6, 17.08.3-1neptune1), libkpimgapicontacts5:amd64 (17.04.1-0neon+20170531+backports+build2, 17.08.3-1neptune1), libkf5kcmutils5:amd64 (5.34.0-0neon+20170531+backports+build13, 5.36.0-0neon+20170531+backports+build14neptune1), systemd-sysv:amd64 (234-3~bpo9+1, 236-2~bpo9+1), libkf5prison5:amd64 (5.34.0-0neon+20170531+backports+build9, 5.36.0-0neon+20171001+1710+build1neptune1), libkolab1:amd64 (1.0.2-3+20170530+1706+build2, 1.0.2-6neptune1), qml-module-org-kde-kholidays:amd64 (17.04.1-0neon+20170531+backports+build6, 17.08.3-1neptune1), libkpimgapitasks5:amd64 (17.04.1-0neon+20170531+backports+build2, 17.08.3-1neptune1), libkf5kcmutils-data:amd64 (5.34.0-0neon+20170531+backports+build13, 5.36.0-0neon+20170531+backports+build14neptune1), libkpimgapi-data:amd64 (17.04.1-0neon+20170531+backports+build2, 17.08.3-1neptune1), libkpimgapicalendar5:amd64 (17.04.1-0neon+20170531+backports+build2, 17.08.3-1neptune1), libical2:amd64 (2.0.0-0.5+b1, 2.0.0-5), libkf5mime5:amd64 (17.04.1-0neon+20170531+backports+build6, 17.08.3-1neptune1), libkf5akonadinotes5:amd64 (4:17.04.1-0neon+20170531+backports+build6, 4:17.08.3-1neptune1), libkf5holidays-data:amd64 (17.04.1-0neon+20170531+backports+build6, 17.08.3-1neptune1), libkf5mbox5:amd64 (17.04.1-0neon+20170531+backports+build7, 17.08.3-1neptune1)
End-Date: 2018-01-08  12:32:52



RE: Sperrbildschirm ausser Funktion - leszek - 01-09-2018 01:18 PM

Oh also der Nvidia Treiber. Möglicherweise macht der den ganzen kram kaputt


RE: Sperrbildschirm ausser Funktion - druuhl - 01-12-2018 01:05 PM

Heute gab es nvidia updates und nun habe ich das Porblem, dass auch das manuelle entsperren aus der Konsole nicht mehr klappt, wegen

- unable to start kmsserver

dannach ist die session tot und ich muss neu einloggen.

Hier meine Aenderungen
Code:
Start-Date: 2018-01-12  08:29:18
Install: libgtksourceview-3.0-common:amd64 (3.22.2-1, automatic), gir1.2-gtksource-3.0:amd64 (3.22.2-1, automatic), meld:amd64 (3.16.4-1), libgtksourceview-3.0-1:amd64 (3.22.2-1, automatic), python-gi-cairo:amd64 (3.22.0-2, automatic)
End-Date: 2018-01-12  08:29:26

Start-Date: 2018-01-12  08:35:28
Install: libelf-dev:amd64 (0.168-1, automatic)
Upgrade: libglx0-glvnd-nvidia:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libglx0-glvnd-nvidia:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libgles-nvidia2:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libgles-nvidia2:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libnvidia-ml1:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-vulkan-icd:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-vulkan-icd:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-driver-libs-i386:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-egl-icd:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-egl-icd:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libglvnd0-nvidia:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libglvnd0-nvidia:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-driver:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-vulkan-common:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-vdpau-driver:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libgl1-nvidia-glvnd-glx:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libgl1-nvidia-glvnd-glx:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libglx-nvidia0:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libglx-nvidia0:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libnvidia-egl-wayland1:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libnvidia-egl-wayland1:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-kernel-dkms:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libegl-nvidia0:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libegl-nvidia0:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-egl-common:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libnvidia-cfg1:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libnvidia-cfg1:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-legacy-check:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-egl-wayland-icd:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-egl-wayland-icd:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-kernel-support:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-driver-libs:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-driver-libs:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-driver-bin:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), xserver-xorg-video-nvidia:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libgl1-glvnd-nvidia-glx:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libgl1-glvnd-nvidia-glx:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-egl-wayland-common:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libopengl0-glvnd-nvidia:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libopengl0-glvnd-nvidia:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libnvidia-glcore:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libnvidia-glcore:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libegl1-glvnd-nvidia:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libegl1-glvnd-nvidia:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libgles2-glvnd-nvidia:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libgles2-glvnd-nvidia:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libnvidia-eglcore:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1), libnvidia-eglcore:i386 (384.98-3~bpo9+1, 384.111-1~bpo9+1), nvidia-alternative:amd64 (384.98-3~bpo9+1, 384.111-1~bpo9+1)
Remove: libgles-nvidia1:amd64 (384.98-3~bpo9+1), libgles-nvidia1:i386 (384.98-3~bpo9+1), libgles1-glvnd-nvidia:amd64 (384.98-3~bpo9+1), libgles1-glvnd-nvidia:i386 (384.98-3~bpo9+1)
End-Date: 2018-01-12  08:36:19

Start-Date: 2018-01-12  11:44:05
End-Date: 2018-01-12  11:44:05



RE: Sperrbildschirm ausser Funktion - leszek - 01-12-2018 09:30 PM

Wir hatten ja bereits einmal angekündigt, dass wir proprietäre Grafiktreiber in Neptune 5 nicht mehr offiziell unterstützen werden.
Ich empfehle einfach den Nvidia Treiber zu entfernen und auf nouveau zu setzen, wenn dieser denn geht.


RE: Sperrbildschirm ausser Funktion - druuhl - 01-13-2018 03:35 PM

Ahh ok, ich hatte das wohl nicht mitbekommen. Mal schaun wie ich mit dem nouvou Bug zurechtkomme


RE: Sperrbildschirm ausser Funktion - druuhl - 02-15-2018 03:02 PM

Inzwischen kamen einige nvidia updates rein und nach dem letzten tut der Sperrbildschirm wieder.