Forums
nvidia graphics - Printable Version

+- Forums (https://www.zevenos.com/forum)
+-- Forum: General (/forumdisplay.php?fid=1)
+--- Forum: Neptune (/forumdisplay.php?fid=21)
+--- Thread: nvidia graphics (/showthread.php?tid=20591)



nvidia graphics - bluheron1 - 10-01-2017 07:39 PM

I'm running Neptune 4.5 and when I did the update today it installed new nvidia updates. Now neptune only boots up to command line. No x server. Any ideas how to fix this? Thanks.


RE: nvidia graphics - leszek - 10-02-2017 09:01 AM

That is unfortunate. Usually it should build the kernel module without a problem. Which kernel have you installed. Can you check if the driver was successfully installed from the tty (terminal) that you can access with pressing ctrl+alt+f1?
All you need to do is trying to reinstall the dkms driver with apt and see if it throws out an error message.
Which driver do you have installed? The legacy one or the more recent 340 version?
Which graphics card do you have?


RE: nvidia graphics - bluheron1 - 10-02-2017 11:11 PM

Hi Leszek. It took me about 12 hours, but I finally got everything working. Had to purge everything nvidia , reboot and then reinstall nvidia from hardware manager. I've been using your distro for about 4 years now. This is the first problem I've encountered. Keep up the good work on your excellent distro. Thanks, Bob.


RE: nvidia graphics - leszek - 10-03-2017 12:01 AM

Nice that you solved it yourself Smile

Thanks for the feedback. We most probably won't do any nvidia driver updates anymore for the lifetime of Neptune 4.5.x


RE: nvidia graphics - bluheron1 - 10-03-2017 10:56 PM

This is my Info for this system, just so you know what I have installed.
About Neptune shows version 3.1
linux image 3.18.72
headers 3.18.72
Neptune Kernel 3.18.72
Neptune base 4.1.7
Neptune KDE desktop 2.5+b1-6
using Nvidia 340.xx driver
Kinfo center shows KDE version 4.14.22
Thanks, Bob.