i have problem with ati driver - Printable Version

+- Forums (
+-- Forum: General (/forumdisplay.php?fid=1)
+--- Forum: Neptune (/forumdisplay.php?fid=21)
+--- Thread: i have problem with ati driver (/showthread.php?tid=15861)

i have problem with ati driver - habbib - 07-31-2015 06:17 PM

my distro is nepune 4.4, my video crs i HD6670, after install driver from end after restart my PC, GUI does not start :/

i`m sorry for my bad English Smile

RE: i have problem with ati driver - leszek - 08-01-2015 01:49 PM

Can you provide the log in /var/log/Xorg.0.log.
And may I ask why don't you stick with the opensource driver that comes preinstalled ?

RE: i have problem with ati driver - renilgh - 05-02-2016 06:43 PM

It seems I have encountered the same issue.
Sadly, the free xserver-xorg-video-radeon driver only runs with glitches, screen flickering, display elements vanishing and overall poor system performance although the card in question actually should be supported as stated in the firmware-nonfree package description.

I don't have the box I tried Neptune on around so I can't tell you which chip exactly it has build in (RadeonHD 6xxx iirc) and can't provide any logs. Sorry for that!

Anyway, here is what I figured after trying to install the proprietary driver through the zevenos-tool, being notified about a successful installation and rebooting to a text-only login:

From the Xorg-logs, the issue seems to be related to dkms. So I removed the fglrx-modules-dkms package and tried to reinstall it by hand. The installation process finishes and marks the package as installed but the modules are not compiled into the kernel. This step is skipped due to the lack of appropriate or matching kernel sources.
IIRC, the systems current kernel was 3.18 but there is no linux-source package of this version. I went back and installed the latest kernel from wheezy-backports. But apparently the catalyst installer wrongly identifies the kernel version through the package names version number which linux-image-3.16.0-0.bpo.4-amd64 while the real image and source version is 3.16.7-ckt25-2~bpo70+1. So the compilation of the dkms-modules is skipped again, since no matching kernel version could be found.

Any help on that matter would be highld appreciated. As stated above, the system is not really usable with the free driver.
Hopefully I'll be able to give you real logs/specs in a few days.

RE: i have problem with ati driver - leszek - 05-02-2016 09:49 PM

Kernel source isn't needed for the driver to compile. Only kernel headers are needed. So the linux-headers package should be enough and the zevenoshardwaremanager should install it for the current running kernel.
Though what might also be is that the fglrx drivers aren't supporting the xserver that we provide.

In all honesty. We are looking in dropping support for proprietary drivers altogether as they break the system every now and then.
So best would trying perhaps a newer kernel like 4.4 that we provide in our repository.

RE: i have problem with ati driver - elvis_ef - 05-03-2016 10:16 AM

I had the same problem with fglrx driver.
Yep, this could be Xserver compatibility issue.
Personally I prefer 3.x kernel, because on 4.x I had many problems with packages.
Also stable packages are preferred by experience.

So, If I have just installed fglrx proprietary driver (using hardware manager provided), without rebooting the system, how can I quickly get back to open source driver?
Because as far as I know, I will have the same problem with this If I restart my system soon.

RE: i have problem with ati driver - leszek - 05-03-2016 12:31 PM

ZevenOS Hardware manager should be able to remove the driver again.
Otherwise remove all fglrx packages installed.