Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved]Keyboard selector problem
01-24-2011, 11:37 PM (This post was last modified: 02-01-2011 11:03 AM by M_Mynaardt.)
Post: #1
Sad [Solved]Keyboard selector problem
Hi!

I can't seem to get the keyboard selector to work properly. I installed the Spanish, Esperanto and Polytonic Greek keyboard layouts through Xfce's options. No problem there.

However, when I try to select one of those keyboards, nothing happens at all! If I'm, say, in a word processor, and select the Spanish keyboard, the cursor leaves the word processor, When I go back to the word processor, the computer deselects the Spanish keyboard and goes back to the default (English) keyboard.

I've used this in other Xfce distributions without problems. Does anyone know why the keyboard selector won't stay on keyboard I've selected?

Thanks...

~*~ M_Mynaardt ~*~
Find all posts by this user
Quote this message in a reply
01-25-2011, 12:52 PM
Post: #2
RE: Keyboard selector problem
I moved the thread to the right subdirectory.

Which keyboard selector are you using ?
The XFCE one you can find under MAGI -> Hardware -> Keyboard ?

If yes switching between German and English here works fine.
Else if no then please try this one.

The default setting is using the system default, which needs to be deactivated under MAGI -> Hardware -> Keyboard .
Visit this user's website Find all posts by this user
Quote this message in a reply
01-26-2011, 06:27 AM
Post: #3
RE: Keyboard selector problem
(01-25-2011 12:52 PM)leszek Wrote:  I moved the thread to the right subdirectory.

Which keyboard selector are you using ?
The XFCE one you can find under MAGI -> Hardware -> Keyboard ?

If yes switching between German and English here works fine.
Else if no then please try this one.

The default setting is using the system default, which needs to be deactivated under MAGI -> Hardware -> Keyboard .

I checked Magi and the keyboard settings again and again. It still doesn't want to work properly. However, I tried doing the same thing on a persistent install of Mint 9 Xfce to see if there was something I was missing from Xfce. And I noticed the problem isn't exactly the keyboard settings.

What is happening is that if I have, say AbiWord running and I left click the keyboard selector; the AbiWord window is deselected! That, I think, is why the keyboards won't switch as I want. But I don't understand how the app window is deselected when I click the keyboard layout icon on the panel in ZevenOS, but when I do the same thing in another Xfce distro, this doesn't happen.

Would there be some other setting I need to look at so that windows don't get deselected like that when I click on a panel button?

Thanks...

~*~ M_Mynaardt ~*~
Find all posts by this user
Quote this message in a reply
01-26-2011, 12:33 PM
Post: #4
RE: Keyboard selector problem
Quote:What is happening is that if I have, say AbiWord running and I left click the keyboard selector; the AbiWord window is deselected! That, I think, is why the keyboards won't switch as I want. But I don't understand how the app window is deselected when I click the keyboard layout icon on the panel in ZevenOS, but when I do the same thing in another Xfce distro, this doesn't happen.

Would there be some other setting I need to look at so that windows don't get deselected like that when I click on a panel button?
So you are using a panel plugin. Changing the keyboard layout in MAGI should work fine as wrote.
I guess maybe it has something to do with the sawfish window manager which deselects your currently open window when clicking on the panel. Try adjusting the Sawfish Settings from MAGI -> Software -> Windowmanager (You need to use a doubleclick to get into the various categories of the settings editor).
In particular you need to take a look at window rules. There should be a rule for the panel. Maybe you need to adjust some settings there regarding the focus of the window ("Never Focus" is one option that comes into my mind)
Please tell me if that works for you. If so I can set it as default for the next release.
Visit this user's website Find all posts by this user
Quote this message in a reply
01-29-2011, 07:43 AM
Post: #5
RE: Keyboard selector problem
(01-26-2011 12:33 PM)leszek Wrote:  So you are using a panel plugin. Changing the keyboard layout in MAGI should work fine as wrote.
I guess maybe it has something to do with the sawfish window manager which deselects your currently open window when clicking on the panel. Try adjusting the Sawfish Settings from MAGI -> Software -> Windowmanager (You need to use a doubleclick to get into the various categories of the settings editor).
In particular you need to take a look at window rules. There should be a rule for the panel. Maybe you need to adjust some settings there regarding the focus of the window ("Never Focus" is one option that comes into my mind)
Please tell me if that works for you. If so I can set it as default for the next release.

Well, I did find the Magi Window manager, but I didn't know which choice to make there. I saw several things to choose from and they all brought up the same menu with different settings whenever I clicked on them. When I first double clicked Window Rules, I got the following choices:
  • ^deskbarv2$
  • ^xfce-panel$
  • ^Docky$
  • ^W
  • ^Gdebi-gtk/gdebi-gtk$
  • ^Synaptic/synaptic$
  • ^Stalonetray$
I'm sure that Docky and Synaptic aren't what I need to look at. Which one of those would I need to double click? I tried "no focus" on the xfce-panel choice, but that didn't help.

I'm sure I'll get this yet! And learn about Swordfish in the process! Smile

Thanks!

~*~ M_Mynaardt ~*~
Find all posts by this user
Quote this message in a reply
01-29-2011, 12:00 PM
Post: #6
RE: Keyboard selector problem
If it does not work this way I am afraid I cannot help you more. I never tested the panel plugin for switching the keyboard layout. I only know switching the keyboard layout from the keyboard preferences works fine.
Visit this user's website Find all posts by this user
Quote this message in a reply
01-30-2011, 01:14 AM
Post: #7
RE: Keyboard selector problem
(01-29-2011 12:00 PM)leszek Wrote:  If it does not work this way I am afraid I cannot help you more. I never tested the panel plugin for switching the keyboard layout. I only know switching the keyboard layout from the keyboard preferences works fine.

NOW it's working properly! I must have done something right without realizing it. Oh well, at least it is working properly.

I assume that the changes I did make didn't take place until after the computer was restarted.

The good news: it works! Cool

The bad news: I don't remember exactly what I did to make it work! Huh

Thanks for the information you did give me. I'm sure that adjusting the Swordfish settings you mentioned must have done the trick. I just wish I could remember exactly what I changed to give you some useful information in the process. Sorry about that... Undecided

~*~ M_Mynaardt ~*~
Find all posts by this user
Quote this message in a reply
12-02-2014, 02:25 PM (This post was last modified: 12-22-2014 04:33 PM by khushfehmi045.)
Post: #8
RE: [Solved]Keyboard selector problem
I do the same thing in another Xfce distro, this doesn't happen.
Would there be some other setting I need to look at so that windows don't get deselected like that when I click on a panel button?




Our excellent online 642-980 exam training programs will lead you to success in the Braindumps exam. We also offer latest cca.edu and hsbc with 100% success guarantee. Our www.principiacollege.edu is rare in IT world.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)