Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linker problem (stretch user) [solved]
08-29-2018, 09:03 PM (This post was last modified: 09-01-2018 04:39 PM by leszek.)
Post: #1
Linker problem (stretch user) [solved]
Hi

I just added your kde repo to my stretch system and almost everything works fine after dist-upgrading:
Pager and task manager cannot start, with error messages like the following:

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/main.qml:26:1: plugin cannot be loaded for module "org.kde.taskmanager": Cannot load library /usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/taskmanager/libtaskmanagerplugin.so: (/usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/taskmanager/libtaskmanagerplugin.so: undefined symbol: _ZN11TaskManager10TasksModel10classBeginEv)

I didn't find out how to solve this problem, so I ask here for support. (I already tried to remove any stretch KDE packages, reinstalled kde-plasma-desktop and plasma-desktop (the latter installs libtaskmanagerplugin.so).

Thanks for any help.

Best,
Bernd
Find all posts by this user
Quote this message in a reply
08-30-2018, 08:56 AM
Post: #2
RE: Linker problem (stretch user)
Try to figure out which version of the package you installed that provides
(/usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/taskmanager/libtaskmanagerplugin.so

Also be sure to have stretch-backports installed as the newest packages are built against it and maybe you are missing a newer lib from there.
Visit this user's website Find all posts by this user
Quote this message in a reply
08-30-2018, 10:07 AM
Post: #3
RE: Linker problem (stretch user)
(08-30-2018 08:56 AM)leszek Wrote:  Try to figure out which version of the package you installed that provides
(/usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/taskmanager/libtaskmanagerplugin.so

Also be sure to have stretch-backports installed as the newest packages are built against it and maybe you are missing a newer lib from there.

libtaskmanagerplugin.so is provided by plasma-desktop which I already reinstalled, and it's indeed the neptune version that is installed.
In synaptic I had a look at all installed packages which are in the KDE section and I removed all packages without neon/neptune in its version name to make sure that no old Stretch packages interfere; afterwards I reinstalled plasma-desktop and kde-plasma-desktop in order to get all required packages. Unfortunately, that didn't solve the problem.

Backports should be enabled (I've several machines, not absolutely sure for this one) - shouldn't required backport packages get pulled in automatically?

Since I just read that you have updated packages now (news from 08/28), might the problem come from some version mismatch inbetween neptune (it shouldn't)?

I won't be in front of the machine before tomorrow evening, I will check then and report back.
Find all posts by this user
Quote this message in a reply
08-30-2018, 09:55 PM
Post: #4
RE: Linker problem (stretch user)
Quote:Since I just read that you have updated packages now (news from 08/28), might the problem come from some version mismatch inbetween neptune (it shouldn't)?
We did not change anything from before when it comes to our build system.

Quote:Backports should be enabled (I've several machines, not absolutely sure for this one) - shouldn't required backport packages get pulled in automatically?
Not necessarily so. On Neptune we set the pin priority over the one of stretch. By default Debian does not do so.
So maybe
Code:
sudo apt -t stretch-backports dist-upgrade
will fix the issue for you. Though create a backup before just to be sure Smile
Visit this user's website Find all posts by this user
Quote this message in a reply
08-31-2018, 08:38 PM (This post was last modified: 08-31-2018 08:41 PM by b80.)
Post: #5
RE: Linker problem (stretch user)
Might the problem be a result of PIN priorities?
I find the following

# apt-cache policy plasma-workspace
plasma-workspace:
Installed: 4:5.12.0-0neon+neptune10
Candidate: 4:5.8.6-2.1+deb9u1
Version table:
4:5.13.4-1 750
750 http://ftp.ch.debian.org/debian testing/main amd64 Packages
*** 4:5.12.0-0neon+neptune10 900
900 https://download.neptuneos.com/repos/neptune5/repo-kde stretch/main amd64 Packages
100 /var/lib/dpkg/status
4:5.8.6-2.1+deb9u1 1000
900 http://ftp.ch.debian.org/debian stretch/main amd64 Packages
1000 http://security.debian.org stretch/updates/main amd64 Packages
1000 http://security.debian.org stable/updates/main amd64 Packages
900 http://ftp.ch.debian.org/debian stable/main amd64 Packages

So if I understand correctly, apt tries to downgrade from the neptune version to the stretch security version, which might not make that much sense.

Questions:
- Am I the first user with this problem?
- How can I solve that problem "correctly"? I should give neptune priority 1000 as well, right? Or even 1001? But how, it's priority is derived from stable/stretch, isn't it? How can that be changed?

Thank you for your support!

PS: Current Pin priorities are:
experimental 1
unstable 50
testing 750
stretch-backports 850
stable 900
Debian-Security 1000
Find all posts by this user
Quote this message in a reply
09-01-2018, 11:12 AM
Post: #6
RE: Linker problem (stretch user)
You can PIN by origin.
So something like this:

Code:
Package: *
Pin: release o=Neptune
Pin-Priority: 777
Visit this user's website Find all posts by this user
Quote this message in a reply
09-01-2018, 03:24 PM
Post: #7
RE: Linker problem (stretch user)
Giving higher priority to NeptuneKDE, it worked (and there has indeed been a libkf5* package needing an upgrade).

Thank you for the great and fast support, I'm enjoying a newer, better KDE now :-)
Find all posts by this user
Quote this message in a reply
09-01-2018, 04:38 PM
Post: #8
RE: Linker problem (stretch user)
Nice Smile
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)