Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
KDE loose keyboard Layout
11-04-2014, 09:47 AM
Post: #1
KDE loose keyboard Layout
Hi,

im using KDE with german language and british keyboard layout.
Im made in the keyboard settings "Use GB Layout systemwide", but there is no change, or it changes to US Layout.
Then i use

setxkbmap gb

in a new konsole windows, a new tab doesnt work, and i can use the GB layout.

My PC is running over night and when i come at the next morning i have again the US layout.

My Settings are:
- Keyboard Model (Generic PC Keyboard 105 intl)
- Layout is set to british or german (main british)

any clue whats going on?


regards
Stefan
Find all posts by this user
Quote this message in a reply
11-04-2014, 08:23 PM (This post was last modified: 11-04-2014 08:24 PM by leszek.)
Post: #2
RE: KDE loose keyboard Layout
If you have problems with the graphical applications to change keyboard layout then try the console way
First we need root rights.
Code:
su
dpkg-reconfigure console-data
dpkg-reconfigure keyboard-configuration
service keyboard-setup restart

I hope that works for you. This however does not change your kde settings which overwrite this global systemsettings.
So I suggest to add both british and german locales to systemsettings -> input devices -> keyboard -> layouts. This allows you to switch also between them with hotkeys if you wish to.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-05-2014, 10:22 AM
Post: #3
RE: KDE loose keyboard Layout
Hi,

i dont have a problem to change my keyboard layout, i have the problem that kde doesnt keep my layout persistent.

That is a problem in the morning with my login, then i can chane my layout with "setxkbmod gb".

Over night kde change the layoyut, why ever.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)