Forums
GPG Error when using apt-get update - Printable Version

+- Forums (https://www.zevenos.com/forum)
+-- Forum: English Sub-Forum (/forumdisplay.php?fid=4)
+--- Forum: Bugs (/forumdisplay.php?fid=13)
+--- Thread: GPG Error when using apt-get update (/showthread.php?tid=14722)



GPG Error when using apt-get update - nachoBA - 01-14-2015 11:44 AM

Hello!
I'm new to the forum, but no to Seven OS. After installing the system and doing and update using the terminal I get the following error:

W: GPG error: http://www.zevenos.com ./ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY D2DAB11CF55D7983

It has to be with the public key, where can I find it?
Thanks in advance
Nacho


RE: GPG Error when using apt-get update - leszek - 01-14-2015 09:58 PM

You can find it here: http://zevenos.com/packages/zevenos6/gpg.key .


RE: GPG Error when using apt-get update - devnullius - 04-27-2017 09:35 PM

Kind of the same question... I just installed ZevenOS and when I go to Synaptic GUI when I refresh the packages lists, I get the following error (in Dutch):

W: GPG-fout: http://www.zevenos.com ./ Release: De volgende ondertekeningen konden niet geverifieerd worden omdat de publieke sleutel niet beschikbaar is: NO_PUBKEY D2DAB11CF55D7983

From https://access.redhat.com/documentation/en-US/Red_Hat_Network/5.0.0/html/Client_Configuration_Guide/ch-gpg-keys.html I did a gpg --import KeyIDownloadedAbove.gpg which went fine. BUT... Synaptic still gives the above error. I'll ignore it for now but kindly advise what to do next Smile

Thanks in advance and... Peace!

Devnullius


RE: GPG Error when using apt-get update - leszek - 04-27-2017 09:53 PM

You need to refresh the repo list again after adding the GPG key.


RE: GPG Error when using apt-get update - devnullius - 04-27-2017 11:12 PM

Ah, I stumbled upon the solution!

Download? You can find it here: http://zevenos.com/packages/zevenos6/gpg.key .
Then?

Start Synaptic
Go to Settings - package sources
Go to the 4th tab: Authentication
Chose for: Import key file (" Sleutelbestand Importeren")
Browse to your download folder in /home/user/Downloads and be done with it Smile

Peace!

Devvie


RE: GPG Error when using apt-get update - leszek - 04-28-2017 09:19 AM

Ah ok. I thought you imported it already.
Great that it works now Smile